Upgrading Store Locator Plus

The base plugin and add ons are updated on a regular basis.  Often the updates include fundamental changes that are designed to improve performance by reducing the memory and/or disk request load when your visitors are interacting with the map.

The most common reason your legacy add on stopped working is because it is no longer supported with the latest version of Store Locator Plus  

Announcements have been made since the end of 2015 that the legacy add ons  are being phased out and at some point will no longer work with the latest version of Store Locator Plus.  As of  4.7 .11 release of SLP, the last of the Legacy Add-ons that were supported, ProPAck will not work with SLP.  Your only option will be to NOT UPGRADE Store Locator Plus.  Make sure you have a backup copy of the current version of SLP you have installed that IS working with your legacy add on packs. We ALWAYS recommend that your site uses VaultPress or JetPack

Whenever you update the base plugin make sure ALL of  your SLP add-on packs are updated to the latest version.

slp-versions-2016-11-27_14-35-46

Upgrading An Add-On Pack

Before upgrading make sure you have a backup and easily-accessible copy of your Store Locator Plus base plugin and add-on packs.    We strongly recommend looking into the WordPress backup, or better option  Jet Pack.   One of the features included , besides real-time incremental backups of your site with restore points, is the ability to restore the site to an alternate site

This should be standard practice before upgrading ANYTHING on your site including WordPress itself.

First upgrade the base plugin.   It is a standard WordPress plugin and the WordPress plugin directory is kept up-to-date with the latest release.  Go to dashboard / updates and click “check again”.   If there is a newer version of Store Locator Plus available it will show up here.  Install the update as usual.

If there are any SLP add-on packs available they should show up on the upgrade list, however the WordPress hooks that query remote servers do not always respond fast enough to notify you when a non-WordPress-hosted add-on pack has an upgrade available.

Follow these steps to manually upgrade your add-on packs:

  • Check the versions list to see what the latest add-on versions are.
  • Go to  your WordPress admin panel plugins page. Compare your installed versions to those listed.
  • Login to your account on the Store Locator Plus website.
  • Download your add-on packs for any that are out-of-date.
  • Via your WordPress admin panel, deactivate and delete the outdated add-on packs.
  • Via your WordPress admin panel, install the zip files you downloaded from the Store Locator Plus site, activate the add-on packs.

Disabled Products

If Store Locator Plus detects a version of an add on pack you have installed is not compatible with the version of the base plugin you just upgraded to , the add on will be disabled automatically.   Re-read the section above on how to manually check your add on versions and update them.  This may be necessary if your server is not playing nicely with our update server.

Keep in mind that legacy add on packs may no longer be supported at some point in the future.

You do NOT have to upgrade to a newer add on to continue using what you purchased in the past, however you might not be able to upgrade the base Store Locator Plus plugin to the latest release at some point in the future.

The legacy add ons have been included in new larger plugins based on functional areas of the add ons.

Legacy products Enhanced Map, Enhanced Search, and Enhanced Results are now part of the Experience add on.

Pro Pack, Tagalong, Pages, Directory Builder, and Contact Extender are part of the Power add on.

Premier Members have access to the Premier Plugin that includes additional functionality only available in the Premier plugin.

Store Locator Plus 4.X With 3.X Add Ons

Mixing Store Locator Plus version 4 with version 3 add-on packs can cause problems on your website and could cause it to crash.  Hopefully NO ONE is using version 3 of anything on WP .   The following error messages may show up on  your admin panel, main web pages, or in the WordPress error logs. If you upgraded your base plugin from SLP3 to SLP4 you must de-activate and delete the older add-on packs and  purchase the SLP4 compatible version.

Add on pack versions 0, 1, and 2 are NOT supported.

The versions info page will show current product versions.