Q: I am receiving error messages and something isn’t working the way it used to, what is wrong?

The most common issue is that there were updates in Store Locator Plus, WordPress, a non-Store Locator Plus plugin, or your theme that may be interacting with and breaking Store Locator Plus.

Update Your Store Locator Plus Add Ons

The first step should always be to check the Store Locator Plus versions page and make sure you are running the latest version of your Store Locator Plus plugins.   There is often a free upgrade to a newer version of a Store Locator Plus add on that works with the current release of the base plugin.

You may need to log into your account at the Store Locator Plus website to download and manually install the updated add on if you are not seeing inline updates through your WordPress admin panel.

Other Plugins Break JavaScript

This is especially true if you recently updated your WordPress install from something older than WordPress 4.5 to 4.5 or newer.   Read this article for details.

https://docs.storelocatorplus.com/blog/q-my-map-is-not-showing-up-what-did-i-do-wrong/

A Code Error Showing Up For SLP Code

Sometimes you will get an error message on your web page that indicates a problem within the Store Locator Plus code. Your webmaster may have turned on WordPress debug mode to learn why your site pages or admin pages are not showing up (the “white screen” from WordPress).

If you receive an error in the Store Locator Plus code please check your add on versions first.  Often we have a newer version of an add on that uses newer method or function calls.

All of our functions and methods are first put through a deprecation notification process that we keep in place for 24 months.   After 24 months we may (and often do) remove the deprecated functions or methods in order to improve the performance of the plugin.   When a function or method is removed that your add on is relying on it will break with a fatal error.

Sometimes we miss something.    Usually because WordPress has changed functionality or deprecated a function within the core code.    We try to code Store Locator Plus to work with the newest release of WordPress AND the older release but sometimes our test scripts don’t catch the regression issues for older versions of WordPress.     On the flip side of the equation, we have been caught using a function that only exists in a newer versions of WordPress.

In either case we try to issue a patch release to address the problem as quickly as possible, however we need to know about the problem then need to reproduce it to create a patch release.   Yes, we’d love to test ever possible scenario but that is impossible with our small team and would be nearly-impossible with even the largest team.   Remember there are over TWO DOZEN versions of WordPress core to test from version 3.8 to the current release.    Double that for multisite variants, and double it again for the differences between subdir and subdomain multisite.   Multiply that by every different version of PHP from 5.2 through the latest release (currently PHP 7) and again for the various PHP libraries you may or may not have installed.    Soon you have millions of combinations to test for every single feature of a plugin.  In other words we rely heavily on YOU to help us test and report issues.

If you find a bug in our code we will do our best to respond quickly and get you back up-and-running.

Asking For Help

The best way to get your questions answered in a manner that is useful to you and others,is to search the forums or documentation.

If you do not find the answer please post your questions in the Store Locator Plus Forum after reading the posting guidelines.  You may want to take a screen shot of your Plug-in Environment, which can be found under the Info tab of your SLP plug-in.