Q. Where can I find an earlier version of the Core SLP plugin?

A. If you need to download an earlier version of the  WordPress StoreLocator Plus developer plugin, go to the WP developers plugin directory.  Select the version you need , download.

You should always back up your site before updating to avoid issues that can occur , especially if you have not been updating your site on a regular basis.  We recommend JetPack.

 

You may also want to check out this article:

Downgrading Store Locator Plus